Might as well make the service native well i'm at it

This commit is contained in:
Tracker-Friendly 2023-12-04 20:45:47 +00:00
parent 3d0dc80298
commit fee59b8028
4 changed files with 74 additions and 0 deletions

View File

@ -0,0 +1,3 @@
type = process
waits-for = loginready
command = dhcpcd -B

View File

@ -0,0 +1,24 @@
From 76ec6a63705e1c3591b4da94c10047a79f0f49db Mon Sep 17 00:00:00 2001
From: q66 <daniel@octaforge.org>
Date: Sun, 20 Dec 2020 15:16:08 +0100
Subject: [PATCH] fix privsep build on ppc*
---
src/privsep-linux.c | 1 +
1 file changed, 1 insertion(+)
diff --git src/privsep-linux.c src/privsep-linux.c
index e588ecd..9d335ca 100644
--- a/src/privsep-linux.c
+++ b/src/privsep-linux.c
@@ -42,6 +42,7 @@
#include <stdlib.h>
#include <string.h>
#include <unistd.h>
+#include <termios.h>
#include "common.h"
#include "if.h"
--
2.29.2

View File

@ -0,0 +1,10 @@
--- a/hooks/10-wpa_supplicant 2014-11-26 16:34:35.000000000 +0100
+++ b/hooks/10-wpa_supplicant 2014-11-28 11:53:48.929217243 +0100
@@ -114,6 +114,6 @@ then
case "$reason" in
PREINIT) wpa_supplicant_start;;
RECONFIGURE) wpa_supplicant_reconfigure;;
- DEPARTED) wpa_supplicant_stop;;
+ DEPARTED|STOPPED) wpa_supplicant_stop;;
esac
fi

37
srcpkgs/dhcpcd/template Normal file
View File

@ -0,0 +1,37 @@
# Template file for 'dhcpcd'
pkgname=dhcpcd
version=10.0.5
revision=2
build_style=configure
make_check_target=test
configure_args="
--prefix=/usr --sbindir=/usr/bin --sysconfdir=/etc --rundir=/run/dhcpcd
$(vopt_if privsep --privsepuser=_dhcpcd) $(vopt_enable privsep)"
hostmakedepends="ntp pkg-config"
makedepends="eudev-libudev-devel"
short_desc="RFC2131 compliant DHCP client"
maintainer="triallax <triallax@tutanota.com>"
license="BSD-2-Clause"
homepage="https://roy.marples.name/projects/dhcpcd"
changelog="https://github.com/NetworkConfiguration/dhcpcd/releases"
distfiles="https://github.com/NetworkConfiguration/dhcpcd/archive/refs/tags/v${version}.tar.gz"
checksum=046b060d72b158f813ea61acc1eff773dea4d9ad035a674ed87ecd95bd35cff7
lib32disabled=yes
conf_files=/etc/dhcpcd.conf
system_accounts="_dhcpcd"
_dhcpcd_homedir="/var/db/dhcpcd"
build_options="privsep"
desc_option_privsep="Enable privilege separation mode for the daemon"
post_install() {
mkdir -p /etc/dinit.d/
cp dhcpcd ${DESTDIR}/etc/dinit.d/
# Enable controlgroup by default, to make dhcpcd-ui work.
vsed -e 's,^#\(controlgroup.*\),\1,' -i ${DESTDIR}/etc/dhcpcd.conf
# License
vlicense LICENSE
}